快捷搜索:

话说三层交换机配置DHCP服务器

在互换机长进行DHCP办事的设置,是我们将要解说的内容。此次主要针对三层互换机设置设置设备摆设摆设DHCP的内容进行先容。办理规划:

一,假如不用互换机的DHCP功能而是使用PC的DHCP功能!

1.在互换机设置设置设备摆设摆设DHCP办事器:

ip dhcp-server 192.168.0.69

2.在互换机中为每个VLAN设置同样的DHCP办事器的IP地址:

interface Vlan11

ip address 192.168.1.254 255.255.255.0

ip helper-address 192.168.0.69 DHCP Server IP

interface Vlan12

ip address 192.168.2.254 255.255.255.0

ip helper-address 192.168.0.69 DHCP Server IP

3.在DHCP办事器上设置收集地址分手为192.168.1.0、192.168.2.0的感化域,并将这些感化域的“路

由器“选项设置为对应VLAN的接口IP地址。

二 使用三层互换机设置设置设备摆设摆设DHCP功能实现多VLAN的IP地址自动分配

(一) 三层互换机设置设置设备摆设摆设DHCP设置设置设备摆设摆设措施一

1.同时为多个VLAN的客户机分配地址

2.VLAN内有部分地址采纳手工分配的要领

3.为客户指定网关、Wins办事器等

4.VLAN 2的地址租用有效刻日为1天,其它为3天

5.按MAC地址为特定用户分配指定的IP地址

三层互换机设置设置设备摆设摆设DHCP终极设置设置设备摆设摆设如下:

ip dhcp excluded-address 10.1.1.1 10.1.1.19 //不用于动态地址分配的地址

ip dhcp excluded-address 10.1.1.240 10.1.1.254

ip dhcp excluded-address 10.1.2.1 10.1.2.19

!

ip dhcp pool global //global是pool name, 由用户指定

network 10.1.0.0 255.255.0.0 //动态分配的地址段

domain-name client.com //为客户机设置设置设备摆设摆设域后缀

dns-server 10.1.1.1 10.1.1.2 //为客户机设置设置设备摆设摆设dns办事器

netbios-name-server 10.1.1.5 10.1.1.6 //为客户机设置设置设备摆设摆设wins办事器

netbios-node-type h-node

//为客户机设置设置设备摆设摆设节点模式(影响名称解释的顺利,如h-node=先经由过程wins办事器解释...)

lease 3 //地址租用刻日: 3天

ip dhcp pool vlan1

network 10.1.1.0 255.255.255.0

//本三层互换机设置设置设备摆设摆设DHCP的pool是global的子pool, 将从global pool承袭domain-name等

option

default-router 10.1.1.100 10.1.1.101 //为客户机设置设置设备摆设摆设默认网关

!

ip dhcp pool vlan2 //为另一VLAN设置设置设备摆设摆设的pool

network 10.1.2.0 255.255.255.0

default-router 10.1.2.100 10.1.2.101

lease 1

!

ip dhcp pool vlan1_john //老是为MAC地址为...的机械分配...地址

host 10.1.1.21 255.255.255.0

client-identifier 010050.bade.6384 //client-identifier=01加上客户机网卡地址

!

ip dhcp pool vlan1_tom

host 10.1.1.50 255.255.255.0

client-identifier 010010.3ab1.eac8

相关的DHCP调试敕令:

no service dhcp //竣事DHCP办事[默觉得启用DHCP办事]

sh ip dhcp binding //显示地址分配环境

show ip dhcp conflict //显示地址冲突环境

debug ip dhcp server {events   packets   linkage}

//察看DHCP办事器事情环境

假如DHCP客户机分配不到IP地址,常见的缘故原由有两个。第一种环境是没有把连接客户机的端口设置为

Portfast要领。MS客户机开机后反省网卡连接正常,Link是UP的,就开始发送DHCPDISCOVER哀求,而此时

互换机端口正在经历天生树谋略,一样平常必要30-50秒才能进入转发状态。MS客户机没有收到DHCP SERVER的

相应就会给网卡设置一个169.169.X.X的IP地址。办理的措施是把互换机端口设置为Portfast要领:

CatOS(4000/5000/6000): set spantree portfast mod_num/port_num enable;

IOS(2900/3500):interface ... ; spanning-tree portfast

(二) 三层互换机设置设置设备摆设摆设DHCP设置设置设备摆设摆设措施二

请参照:若何在三层互换机上实现跨VLAN 的DHCP设置设置设备摆设摆设

您可能还会对下面的文章感兴趣: